Creating a bootable USB stick from an iso file on Mac OSX
I wanted to load ReactOS on an old laptop of mine.
Steps followed to create the bootable USB stick
hdiutil convert -format UDRW -o /Users/santoshsrinivas/Downloads/ReactOS-0.4.0.img /Users/santoshsrinivas/Downloads/ReactOS-0.4.0.iso
#diskutil unmountDisk /dev/diskN
diskutil unmountDisk /dev/disk2
sudo dd if=/Users/santoshsrinivas/Downloads/ReactOS-0.4.0.img.dmg of=/dev/rdiskN bs=1m
#diskutil eject /dev/diskN
diskutil eject /dev/disk2
Reference: How to create a bootable USB stick on OS X | Ubuntu